Installing Lotus Sametime 8.5.1 embedded client on Ubuntu

less than 1 minute read

We have recently tried installing Sametime 8.5.1 embedded client for Lotus Notes 8.5.2 on Ubuntu. Comparing with the Notes client itself, which we installed without any problems, the Sametime client wasn’t that easy since we got this error:

dpkg: error processing /home/az/Downloads/sametime-connect-embedded-8.5.1.i386.deb (--install):
parse error, in file '/var/lib/dpkg/tmp.ci/control' near line 10 package 'sametime-connect-embedded':
duplicate value for `Depends' field

We looked in Google and found nothing regarding this error, after that we decided to try solving it ourselves and it actually worked.

az@az:~/Downloads/ST$ mkdir sametime-connect-embedded-8.5.1.i386
az@az:~/Downloads/ST$ cd sametime-connect-embedded-8.5.1.i386/
az@az:~/Downloads/ST/sametime-connect-embedded-8.5.1.i386$ mkdir DEBIAN
az@az:~/Downloads/ST/sametime-connect-embedded-8.5.1.i386$ cd ..
az@az:~/Downloads/ST$ dpkg -e sametime-connect-embedded-8.5.1.i386.deb ./sametime-connect-embedded-8.5.1.i386/DEBIAN/
az@az:~/Downloads/ST$ dpkg -x sametime-connect-embedded-8.5.1.i386.deb ./sametime-connect-embedded-8.5.1.i386/

Then in the DEBIAN/control file we removed duplicate Depends and Pre-Depends and saved the file.

Following by packaging:

az@az:~/Downloads/ST$ dpkg -b ./sametime-connect-embedded-8.5.1.i386 sametime-connect-embedded-8.5.1.i386-ver2.deb

and installation from the new package – worked fine!